CUDA 9 issue: Got an error '__CUDACC_VER__ is no longer supported.' while compiling QtPlatz

I've prepared new debian 9 install on HP 640 Workstation equipped with Quadro M4000 GPU.  Install CUDA 9 RC (, and all dependent software for QtPlatz build.  I got an error while compiling as "__CUDACC_VER__ is no longer supported." message.  After few hours search, I've figured out it came from include/boost/config/compiler/nvcc.hpp.

Just dirty hack, comment out the line, then cuda compilation went through.



User login