Quartus Prime Lite on Debian9 memo

Quartus Prime Lite does not officially support Debian though...

Download 'Quartus-lite-', expand tar file and execute setup.sh can be done on Debian9.  However, /opt/intelFPGA_lite/17.0/quartus/linux64/quartus cannot be started due to no libpng12.so.0 found.  After hours of web search, I've found it can be downlaod .deb package for Ubuntu and it worked.


One more issue, when add /opt/intelFPGA_lite/17.0/quartus/linux64 to LD_LIBRARY_PATH, emacs command will no longer work.  So, I've added following alias in .bashrc

alias quartus='LD_LIBRARY_PATH=/opt/intelFPGA_lite/17.0/quartus/linux64 /opt/intelFPGA_lite/17.0/quartus/linux64/quartus'


User login