Build on Linux & Mac

English

Prerequisite for Linux (Debian Jessie/Stretch amd64)

  1. Debian 8.1 (Jessie) installed.
  2. Install required tools using apt-get;
    • sudo apt-get install git cmake build-essential 
    • sudo apt-get install mesa-common-dev libxml2-dev libxslt1-dev
    • sudo apt-get install bc libncurses5-dev
      
    • sudo apt-get install libgstreamer-plugins-base0.10
  3. Download Qt5 installer from http://www.qt.io/download-open-source/. You may get it by either one of following command;
    • wget http://download.qt.io/official_releases/online_installers/qt-unified-linux-x64-online.run
    • wget http://download.qt.io/official_releases/qt/5.6/5.6.0/qt-opensource-linux-x64-5.6.0.run
  4. Download boost and qwt sources
    • wget http://sourceforge.net/projects/boost/files/boost/1.59.0/boost_1_59_0.tar.bz2/download
      mv download boost_1_59_0.tar.bz2
    • wget http://sourceforge.net/projects/qwt/files/latest/download?source=files
  5. Install Linux kernel headers (This is required only if need 3rd party kernel driver build, e.g.  Keysight/Acqiris digitizers)
    • sudo apt-get install linux-headers-$(uname -r)

Install QtPlatz on Linux (Debian Jessie amd64)

Follow steps below;  The installation of RDKit (chemistry engine) and TAO (CORBA library) is optional.

  1. Install Qwt library
  2. Install Boost library
  3. Install RDKit (optional)
  4. Install TAO (optional)

Build QtPlatz

git clone git://github.com/qtplatz/qtplatz.git cd qtplatz ./bootstrap.sh cd ../build/qtplatz-x86_64.release; make -j4

bootstrap.sh create build directory in ../build/qtplatz-$arch.(release|debug) by using cmake


Prerequisite for Linux MultiArch cross compile (Debian Jessie amd64 host, armhf target)

  1. Install all qt libraries listed in previous section for target archtecture, 'armhf' for example.
  2. apt-get install qemu, if not yet installed.  (for run target qmake binary on host system)
  3. make symbolic link
cd /usr/lib/arm-linux-gnueabihf/qt5/bin
ln -s /usr/lib/x86_64-linux-gnu/qt5/bin/moc .
ln -s /usr/lib/x86_64-linux-gnu/qt5/bin/rcc .
ln -s /usr/lib/x86_64-linux-gnu/qt5/bin/uic .

Prerequisite for Mac OSX

  1. Install Xcode and it's command line tools
  2. Install git and cmake
  3. Install Qt5 by either using installer and/or build from source.

User login